PHP-Aprender: Primeira página – parte 3

Vamos criar a nossa primeira página de exemplo. Utilizaremos os códigos do PHP embutido no HTML.

Abra o seu editor preferido, digite os códigos abaixo e salve com o nome “inicial.php” (sem aspas dupla). Para aqueles que instalaram o WAMPSERVER, os arquivos devem ser salvos no diretório www da instalação.

<html>
<head>
   <title><? echo "Minha primeira página"; ?></title>
</head>
<body>
<?
   define ("curso", "Aprender PHP");
   $nome = "Fulano";
 
   echo $nome . " está fazendo o curso " . curso;
?>
</body>
</html>

Como rodar este script no browser?
Abra o seu navegador e digite o endereço: http://localhost/inicial.php

Resultado:
Fulano está fazendo o curso Aprender PHP

Explicando:

No código acima estamos demonstrando como funciona um script executado no servidor.

echo é a instrução que imprime o resultado na tela, pode ser qualquer informação – textos, números ou variáveis.

= ” é um operador de atribuição. ex: O texto “Fulano” é atribuído a variável $nome.

. ” é um operador de concatenação. Permite juntar strings (textos) com variáves.

6 comentários em “PHP-Aprender: Primeira página – parte 3

  • 1 de maio de 2011 em 12:36
    Permalink

    Olá,

    fiz tudo que vc pediu na primeira página. Escrevi o código e salvei como “inicial.php”. Estou usando o xampp para testar, mas quando digito http://localhost/inicial.php, aparece somente uma pagina em branco. Preciso de um banco de dados para rodar essa pagina? Criei um banco com o nome pagina_teste. Preciso criar uma tabela agora? Que tipo? E depois de criada, o que faço?

    Um grande abraço
    Everaldo

    Resposta
  • 1 de maio de 2011 em 13:00
    Permalink

    Apareceu apenas uma página em branco quando digitado o código acima, não temo que inserir o código abaixo em algum lugar?

    Resposta
    • 2 de maio de 2011 em 9:50
      Permalink

      Olá Everaldo,

      este problema não está no código e também não é necessário criar banco de dados.

      Provavelmente o arquivo php.ini da instalação do xamp não está configurado para utilizar short tags, quero dizer, não é interpretado as tags iniciais no formato <? ?>. Faça o seguinte, mude para <?php ?> e veja se funciona.
      Abraços.

      Resposta
  • 25 de maio de 2011 em 1:47
    Permalink

    Também a minha página ficou em branco!!Alterei as tags <? e continuou em branco..

    Resposta
    • 25 de maio de 2011 em 7:57
      Permalink

      Olá Walton,

      todos os códigos postados no blog são testados antes.

      Fiz o teste mais uma vez e está tudo ok.

      Resposta
  • 10 de setembro de 2011 em 19:35
    Permalink

    Pessoal, verifiquem se a página está carregando a partir do localhost (http://localhost/minhapagina.php), senão vem em branco mesmo. Aqui primeiro instalei o WampServer, é muito melhor…

    Resposta

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *